Subject: PC hires source

From: [email-masked] (Greg Alt)
Date: Tue, 8 Oct 91 21:50:49 -0600

I uploaded source code for a PC...  I converted the ST code and fixed it up
a little.  I was thinking, we should probably have a standard interface of
some sort so that our code will be relatively compatible.  Here is my proposal:

typedef struct _glove_data {
   unsigned char dum0;
   signed   char x,y,z;
   unsigned char rot,fingers,keys,dum7,dum8,dum9,dumA,dumB;
   } glove_data;
 
void Hires();
void getglove(glove_data *);

possibly better function names would be glove_init() and glove_sample()
Also, the byte that I called "dum9" seems to be used to tell if the glove
is not aimed at the receivers.  
 
One more thing I was wondering about...  In the initialization function,
it looks like 7 bytes are sent to the glove.  I wonder what the significance
of these is...  The reading of the first few bits is probably to tell if 
a glove is really attached.  The other thing to start brainstorming about is
how to solve the problem of the 5 long pauses.  Each one is 14 milliseconds,
so you waste 70 milliseconds per sample.  Surely something useful could be
squeezed into that time somehow.  Also, that only gives us 14 samples per
second (assuming nothing else is done between samples).
 
Tonight I plan on experimenting with the finger input (I played around
with x,y,z, moving a simulated 3D cursor around, and it was kind of interesting)
        Greg

---

From: [email-masked]
Date: Wed, 09 Oct 91 14:31:22 -0400

Greg Alt writes:

-----

  We use init_glove() and query_glove(), if we are comparing.  But I don't understand about the 'dum9'.. how does the glove know if it is not pointing to sensors?  I never knew it could do that.  Is that the same as receiving bad data?

	David Barberi
	Syracuse University Virtual Reality Lab