Subject: sega glasses available?

From: [email-masked] (John D Beutel)
Date: Tue, 15 Oct 91 14:14:51 EDT

Does anyone know where Sega 3D glasses are available (and $)?
(Or another type, I guess, and cost?)

--
J. David Beutel  11011011  [email-masked]  "I am, therefore I am."

---

From: [email-masked] (John D Beutel)
Date: Thu, 17 Oct 91 21:06:04 EDT

I called Sega USA tonite (1-800-USA-SEGA) and the guy I asked
said that they would sell the 3D glasses by themselves,
over the phone with a credit card or thru the mail by check.

	34.95	3D glasses
	+2.80	postage & handling

	ATTN: Parts and Orders Dept.
	Sega America
	3375 Arden Rd.
	Hayward, CA  94545

I haven't ordered one yet, but that's probably the way I'll do it.

---

From: Greg Newby <[email-masked]>
Date: Fri, 18 Oct 91 12:05:21 -0500

For the circuit, has anyone tested it out?  It appears that
you hook in the Sega glasses, and then send a signal to switch
the LCDs (from left-on, right-off to left-off, right-on).  

The signal is sent via pin 4, which is not the regular pin
for reading or writing data.

So, the question is, what's involved in switching the signal?
If it's a call to termio() or somesuch, what sort of speed
limitations are we talking about?  I didn't check the
RS232 standard just now, but I wonder about the +/- 10V switching
signal -- isn't that rather 0-12V?  (effectively, probably
+/-3 to 8-12V).

Finally, does anyone have the tech specs on the glasses (or 
an estimate, as I suspect Sega doesn't include such things
with the glasses)?  Switching speed, %dark, etc...

With the brain trust we have on this list, I'm not too worried
that someone will figure out how to hook in the glasses.  I'm
just wondering in advance if performance (especially switching
speed) will be up to snuff.  
	(For example, to give some numbers, we need a minimum
	 of about 10 frames per second to perceive continuity
	 between frames of a moving scene.  That means the glasses
	 need to switch 20 times per second, right?  A left-right
	 sequence for each frame.
		If there's more than a few u-second lag for the
	 glasses to switch, we'll have to compensate in the
	 display program.  Being that we're usually using all
	 the computing power we have just to keep the graphic
	 images coming fast enough, incorporating some sort
	 of delay for the glasses would be undesirable.)

Oh, BTW: I've done a bit of experimenting (back at Syracuse) with
some Tektronics shutter glasses -- a very similar beast, tho
presumably higher performance.  I found that the flicker was
perceivable at 30Hz (60 switches / second), and intolerable
(read, "doesn't work") at about 7-15 Hz.  I didn't experiment
with the full range....this was because the software-driven
switching circuit never operated more quickly than about 15Hz.

Ok, I'm rambling now:  the alternative, to get 30Hz, is to 
NOT switch the glasses via software.  Just let them operate
at the frequency of the power supply (60Hz in the US, which, in
the circuit we used @ Syracuse, was run through a rectifier).
Then, no coordinating between your graphics program and the
glasses are necessary, PROVIDED that your program is able to 
operate at "top-speed," switching the image on the screen
as often as possible (as in, the speed of the power supply).
 	I don't know if this technique works for all platforms,
but it worked on the Amiga and Iris we used at Syracuse.  I even
synched the glasses off of a Sony VCR/editor to look at 
the display on the Iris.

'Nuff said.
-- Greg
[email-masked]

---

From: Dave Stampe-Psy+Eng <[email-masked]>
Date: Fri, 18 Oct 91 14:10:33 -0400

> From [email-masked] Fri Oct 18 13:25:24 1991
> From: Greg Newby <[email-masked]>
> To: [email-masked]
> Subject: Re: sega glasses available?
> Cc: [email-masked]
> 

Here's the EXACT driving specs on the Sega, Haitex, and X-Spec glasses.  These
all use the same type of LCD pi-cell.  They are normally fairly dark (30%
transmissive) and drop to 1% transmissive (very dark) when sent a 24V. 2 KHz
signal (square wave).  Do not accept drivers that use lower frequencies 
or voltages, as these will not become fully opaque!

I spent several month designing drivers for these things about a year ago.
We used both computer and video (alternating-field) signals to drive them.
I have the following designs:
- A 5V supply design with a flyback power supply
- A 12V supply design using push-pull drive
- A (theoretical) design using the RS232 port of a computer and 4 components.

This last design has not been built or tested yet, as I temporarily do not 
have access to glasses.  However, if you want to try it, go ahead.  Just tell
me it it works.

Basically, you hook the outside (common) of the glasses connector (use a 
Walkman-type stero phone jack) to the ground pin of the RS232 port.
Connect 2 of 2.2K resistors to the TX pin.  Connect a 1N914,1N4005, etc.
diode's cathode to the DTR and another to the RTS pin.  Connect one anode of 
diode and one of the resistors to each of the pins on the glasses jack. THAT'S
IT.

The software is a bit complex.  Basically, you have to set up an interrupt to keep the TX buffer of the serial port stuffed with $55's.  Set the baud rate
to 4800 baud, and voila! a 24V 2200 Hz output.  Raise and lower the DTR and
RTS pins (via the UART in the PC) to turn the pulses to each eye on and off.

This should work on any PC that supplies at least +/-10V (the RS232 standard
is +/- 12V).  Interrupt loading is not terribly high: about 5-10%.

No guarantees that this will work, but it would be pretty easy to try.

-Dave Stampe

---

From: Juri Munkki <[email-masked]>
Date: Fri, 18 Oct 1991 21:39:28 +0200

The Sega glasses really do operate with +/- 10 V. I haven't tried anything
higher, but I do know that they work with +/- 9V. You have to be particularly
careful not to feed any DC to the glasses, because it will break the shutters.

The % darkness is supposedly around 60%. On the Macintosh it's not a problem
to switch the glasses at vertical blanking time (the operating system has
support for installing tasks to run at VBL time), so on my monitor at home,
I get 66 switches per second (a frame rate of 33 Hz). The new 21" monitor
from Apple uses 75 Hz, so there should be almost no flicker.

I hope all Mac users on this list are aware of the Macintosh-compatible
interface and the sample application that I wrote for it. I don't know
if it is any longer possible to connect the glasses and the glove to the
same serial port now that we know how to access the hi-res mode. (I haven't
looked at the code, but I expect someone to come up with a Mac version
really soon now.)

Juri

---

From: Lance Norskog <[email-masked]>
Date: 18 Oct 91 13:25:25 PDT (Fri)

Another source of glasses is a product from Haitex (inc. or something)
in Charleston, S. Carolina.  These are surplus Nintendo glasses
packaged with a box half the size of a cigarette pack.  The
box takes 5V, Ground, and a control line and controls one or
two goggles.  These are built for the Amiga and should be
available from a hip Amiga dealer near you.  The Haitex BBS had
the pinouts for the 9-pin Amiga joystick connector; I've got
them stashed somewhere.  The things list for $110 and are
built and solidly packaged.  A deal for we non-electronics types.

The Nintendo goggles (welder's helmet actually) were never marketed
in the states.

Lance Norskog